Mot clef : Windows 7

IIS 7, MySQL et problèmes de connexion

par Jean-françois JOLY le jan.01, 2010, dans Developpement Web

Si tout comme moi, vous décidez d’installer php 5.3 sur un serveur IIS 7 sur windows 7 afin de tester un petit peu en local, vous risquez de vous trouvez confronter a quelques petits problèmes de configuration. Aujourd’hui je vais vous faire part d’un petit soucis très bête que j’ai rencontré au cours de mon installation …

Petit résumé de l’histoire :
J’avais quelques sites sur un serveur LAMP et un beau jour j’ai décidé de changer car j’avais très envie de m’essayer a developper en autre chose que du php.
Etant l’heureux propriétaire d’une licence windows 2003 Server standard édition. J’ai donc migré et installé php 5.3 et mysql 5.1 dernier cru afin de conserver mes sites. Tout marche nickel chrome.
Bien sur je ne compte pas abandonner le php au profit d’un autre langage, mais plutôt essayer ‘élargir mes horizons. A cette fin je décide d’installer mon attirail du développeur sur mon PC pour faire du développement en local. Afin de bien coller à ma nouvelle problématique je vire apache et j’installe php 5.3 pour IIS. Problème : je suis sous windows 7 et c’est donc IIS 7 qui est installé sur mon pc. Autre problème : je récupère mes sites, mes dbs mysql, tout est configuré comme sur mon serveur win 2003. Et là c’est le drame : erreur de connexion à la db. Bien sur pour couronner le tout, j’ai une alternance d’erreurs : erreur interne du serveur et le simplem message du trigger quand la connexion à la base échoue …

Après moulte recherche, je pensais que ça pouvait être du à la version 32bits de php alors que je suis en windows 7 64bits, j’ai pensé à un problème de configuration dans php.ini, a un problème de réglage de droit dans le pool d’application, a un complot cosmique dans le but de me rendre fou …

La solution était bien plus simple que ça … Il se trouve que le bon vieux fichier d’hosts de windows 7 (system32/drivers/etc/hosts) a une ligne commentée : 127.0.0.1 localhost
Et moi bien sur, dans mes fichiers include php, pour mes chaines de connexion mysql, j’utilisais localhost comme host … Forcément ça ne risquait pas de marcher.

2 Commentaires :, , , , plus...

A la recherche de quelque chose ?

Utiliser ce champs pour faire votre recherche :

Vous n'avez pas trouvé votre bonheur ? N'hésitez pas à contacter l'auteur de ce blog ou alors laissez un commentaire sur un post !

Les liens !

Quelques liens intéressants...

Les archives

Tout, classé par ordre chronologique ...